Zaptec API outage
Incident Report for Zaptec
Postmortem

Between 03:50 and 07:25 we experienced an outage on our public API. This was caused by our monitoring system reacting incorrectly when all API services became simultaneously unavailable for a brief moment. This led to the whole class of services being classified as unavailable and unable to process requests, which in turn prevented the system from self-healing. Our engineers identified and corrected the problem, bringing the API back online. We also introduced a change that ensures at lease one resource is kept operational to enact self-healing in case of a general outage.

Posted Nov 20, 2023 - 16:29 CET

Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 03:30 CET